LuchoWiki

Cosas que debería hacer más a menudo

User Tools

Site Tools


proyectos:taller-redes:contenidos:configurando-router-cisco

Configurar Router Cisco

Proceso de configuración del router Cisco Systems 831 Series [Router CISCO 831 (800 Series)\\ modelo usado en la Universidad del Mar]

Se utilizará como router principal (superior) un Cisco 831 Series para la estructura de la red representada aquí.

Prerequisitos

Los siguientes paquetes deben estar instalados en la máquina local:

  • minicom: equivalente de HyperTerminal para Linux (Debian).
[root@machine] apt-get install minicom

Configuración

1.- Conectando el Router

Se conecta el router al puerto serial de la máquina. Esto debe hacerse con la máquina apagada.

2.- Asignando el Puerto Serie

Lo primero es (ya con la máquina encendida) chequear que los puertos seriales NO están en uso por ninguno de los shell del sistema, ya que el Router provee su shell propio. Para esto basta con desactivar la interface correspondiente al puerto serie en uso (por ejemplo, ttyS0') en el archivo /etc/inittab; la forma más fácil es simplemente comentando la línea.

Para liberar la comunicación con el puerto serie, lo hacemos chequeando si hay procesos con la terminal serial abierto:

[root@machine] ps -ef | grep ttyS

Si el comando no nos entrega salida, tenemos acceso a la terminal. Para eso simplemente chequeamos que en el archivo inittab no existan las referencias a la terminal serie.

En cambio, si el comando entrega salida, ésta nos indicará en qué puerto serie está abierta esa terminal. Debemos tener cuidado que el proceso que se está ejecutando debe ser un login como getty o similar; si es un programa o proceso diferente, es probable que otro usuario esté haciendo uso del puerto serial.

Para cerrar el proceso de login simplemente usamos el comando kill pasando como argumento el PID del proceso que hemos detectado.


Una vez liberado el acceso al puerto serie, ejecutamos minicom.

[root@maquina] minicom
 
Welcome to minicom 2.2
Port: /dev/ttyS0
 
Router> 
[Captura de pantalla de la conexión inicial a //minicom//.]

Si nuestra sesión se ejecuta en un puerto diferente a ttyS0 (o al puerto que sea que hemos conectado el router), debemos usar las opciones Ctrl+A, O para acceder a la configuración y cambiar el puerto en uso.

Usando la combinación de teclas Ctrl+A, P, entramos a la sección de configuración y seguimos las instrucciones para establecer el modo de conexión al módem (router) como sigue:

Velocidad 9600 baudios
Bits 8
Paridad no
Bit parada 1
Corrección por Software no

Si todo sale bien, la conexión debe establecerse con la etiqueta 9600 8N1.

Presionamos Ctrl+A, M para marcar al módem.

3.- Accesando al Shell CISCO

Deberíamos recibir la siguiente respuesta (asumiendo que “UdelMar” es el nombre del router):

UdelMar>

Eso nos entrega una terminal indicando la conexión, y el nombre del shell. Aquí podemos escribir los comandos o acceder a las teclas rápidas de minicom por medio del acelerador Ctrl+A. Algunas combinaciones que hay que conocer:

Ctrl+A + …
D Acceder al gestor de dialing para conectar a varios posibles modems o routers
F Enviar un comando Break (SysBrk) al módem
H Colgar la conexión con el módem
J Salir a una terminal temporalmente
L Activar/desactivar la captura de salida desde nuestra terminal hacia un archivo
M Marcar al módem o router
P Entra a la pantalla de configuración de parámetros de comunicación: bitrate, paridad, etc…
Q Salir de Minicom, reiniciando la terminal pero no el modem
X Salir de Minicom, reiniciando tanto la terminal como el modem
Z Ayuda

Ya en el prompt, escribimos lo siguiente:

Udelmar>enable

Esto nos pedirá la contraseña del router, la cual es: xxxxxxxxqué creían, ¿que la iba a colocar aquí? . Si no es posible acceder o no se conoce la contraseña, ver las instrucciones para resetear la memoria del router.

Y con esto hemos logrado acceder al shell, demostrado porque el prompt cambia al prompt “tipo root” de Debian:

Udelmar#

4.- Configurando el Router

Creando la Configuración por Defecto

Ver la sección sobre reseteo del router.

Prompt de Interfaces

Lo primero es tener una mirada rápida de los comandos:

Comando Prompt Efecto
show running‑config Muestra la configuración actual o la configuración grabada del router.
configure modo router Accede al modo de configuración el cual puede ejecutarse desde la terminal (terminal) o desde la red (network).
exit router(config)> Sale del modo de configuración.
write router Escribe la configuración actual al sistema rígido (configuración para el siguiente booteo).
reload router Recarga la configuración del router.

Con estos comandos, lo primero que hacemos es obtener un dump de la configuración actual del router, a modo de backup:

show running-config

Una vez obtenida esta configuración vamos a proceder a configurar las interfaces de red.

Conectando y desconectando cables, se ha descubierto empíricamente (gracias a observaciones por parte de Exel) que la estructura física de las bocas de red es como sigue:

Boca Ethernet Boca FastEthernet
Ethernet1 FastEthernet0 (WAN)
Ethernet0 FastEthernet[1-4] (LAN)

Además, revisando el manual se ha descubierto que las interfaces FastEthernet se configuran autónomamente en modo [Half|Full]Duplex y que solamente se configura la interface Ethernet0 con la dirección de gateway.

Con esta información, procedemos:

configure terminal

Con esto el prompt cambia al Modo de Configuración y utilizamos la instrucción interface para configurar la interface:

UdelMar(config)> interface Ethernet1
UdelMar(if-config)>

El prompt cambia para indicarnos que hemos accedido a la configuración de red (Udelmar if-config). Utilizamos la sintaxis para agregar la configuración de la interface de red:

[no] ip address //ip_adress// //netmask// 
UdelMar(if-config)> ip address ip_asignada netmask1)
UdelMar(if-config)> no shutdown
UdelMar(if-config)> description Una descripción que queramos darle a la interface

; donde ip_asiganda es la IP con la que salimos a la red superior y netmask su correspondiente máscara.

El comando no shutdown asegura que la interface siga levantada cuando la configuración se aplique de forma local (volátil). Necesitamos esto para saber que la interface está funcionando antes de aplicar la configuración a la memoria no volátil. Finalmente el comando description nos permite agregar comentarios para identificar la interface (útil considerando que, como se vio más arriba, las interfaces tienen una enumeración lógica “extraña”).

Salimos de la interface Ethernet1 con exit:

UdelMar(if-config)> exit
UdelMar(config)>

Y procedemos a configurar la interface Ethernet0 (el acceso LAN):

UdelMar(config)> interface Ethernet0
UdelMar(if-config)> ip address 192.168.1.1 255.255.255.0
UdelMar(if-config)> no shutdown

; recordando sustituir 192.168.1.1 por nuestra dirección como Gateway interno (así como sustituir la máscara correspondiente) si estamos usando un ruteo diferente del establecido.

Salimos de la configuración de la interface:

UdelMar(if-config)> exit

5.- Configurando las Redes

Reglas de Routing

[Diagrama inicial de redes del Laboratorio (2008).]

Si seguimos las reglas para nuestra red inferior (192.168.1.0/25) para que quede como en el gráfico de la estructura de red, podremos salir hacia afuera, pasando nuestra estructura de red al router superior (ruteo) o escondiéndola bajo una sola IP (nateo). En un Router Cisco esto se hace con los comandos ip route… e ip nat ….

Para aplicar la configuración de ruteo, el primer paso (si el router está blanqueado) es activar la opción de ruteo:

UdelMar(config)> ip routing

Luego simplemente utilizamos el comando ip route que recibe tres parámetros: la red a la que queremos alcanzar, la máscara con la que debemos salir, y a qué router debemos preguntar.

UdelMar(config)> ip route 0.0.0.0 0.0.0.0 defaultip_gateway|IP del gateway para nuestra red superior

Esta regla direcciona cualquier petición al gateway superior; es equivalente a la directiva de ruteo route add default en Linux.

Finalmente, en algunos modelos, la configuración rápida luego de un reseteo no establece algunas banderas y configuraciones que Cisco llama “Cisco Express Forwarding” y que tienen que estar habilitadas para que la mayoría de los protocolos forwardee correctamente. Para (re)habilitarlos, ejecutamos el siguiente comando:

UdelMar(config)> ip cef

Reglas de NAT

Como en la Universidad estamos detrás de una NAT, no podemos simplemente aplicar las reglas de ruteo, no van a funcionar. Sin embargo, sí podemos usar NAT para poder conectar las redes y también para salir al exterior usando solamente la IP que ha sido asignado a nuestro router.

Para empezar, entremos a la configuración y seleccionemos las interfaces que componen la parte interna (inside) y externa (outside) de la NAT.

UdelMar> configure terminal
UdelMar(config)> interface Ethernet0
UdelMar(if-config)> ip nat inside
UdelMar(if-config)> exit
UdelMar(config)> interface Ethernet1
UdelMar(if-config)> ip nat outside
UdelMar(if-config)> exit

Aquí hemos configurado que las puertas que componen la LAN (Ethernet0) serán el lado interno de la NAT. Es aquí donde colgaremos máquinas.

La NAT en sí está configurada; ahora es necesario crear la configuración de enmascaramiento, la cual consiste en seleccionar qué IPs van a ser nateadas y cuál va a ser la IP defaultpública|hacia arriba de su red con la cual van a salir. Esto se hace en dos pasos:

  • primero, configuramos una lista de acceso con las IPs que están aprobadas para nateo (las que componen el lado interno):
UdelMar(config)> access-list núm permit 192.168.1.0 0.0.0.255

Lo que estamos diciendo es que la lista de acceso núm (por ejemplo, 1) contendrá las IPs de la red 192.168.1.0 que queden cubiertas por el broadcast .255 (es decir, todo el segmento de 256 direcciones).

  • segundo, configuramos una piscina de IPs de salida con las IPs que deben ser asociadas en la traslación; en nuestro caso usamos una sola IP, la de nuestro Gateway:
UdelMar(config)> ip nat pool piscina ip_inicio ip_fin netmask máscara

Lo que estamos diciendo es que la NAT debe traducir direcciones resultando en una dirección IP cualquiera entre ip_inicio e ip_fin, usando para ello la máscara indicada, y a ese conjunto de traslaciones se le asignará el nombre piscina.

  • tercero y final, asociamos la lista de acceso del lado interno con la piscina de direcciones del lado externo:
UdelMar(config)> ip nat inside source list lista pool piscina

Lo que hemos hecho es decir al router que para realizar traslaciones hacia la piscina piscina, debe usar direcciones fuente (“source”) que estén indicadas en la lista lista.

En nuestro ejemplo particular, si llamamos a nuestra lista de acceso “666” y a nuestra piscina “microsoft”, nombres y números que no necesariamente guardan relación con la realidad2), el comando resultante sería:

UdelMar(config)> ip nat inside source list 666 pool microsoft

Una vez ejecutados estos comandos, la traslación está lista; desde este punto, podemos conectarnos a la red con cualquier máquina ubicada dentro del área nateada (nuestra red 192.168.1.0/25), pero para el mundo exterior sólo existiremos como una de las direcciones de la piscina.

Para verificarlo, abramos nuestro navegador web (uno decente como Opera|favicon|fetchname="tooltip"| o Firefox, o incluso Links (navegador)), y busquemos alguna de esas páginas que nos reporta nuestra IP, por ejemplo:

Si hemos ejecutado el NATeo correctamente, nuestra IP reportada será una de las que hemos asociado en la piscina.

Sirviendo DHCP

Creando un Túnel SSH

6.- Respaldando la Configuración

Para respaldar los cambios de configuración que hemos realizado, es tan sencillo como salir del modo de configuración, esperar que ésta se actualice en la consola, y escribir en la terminal base de configuración:

UdelMar> write memory

Esto escribe los cambios y la nueva configuración a una memoria no‑volátil que se activa de inmediato y permanece activa una vez reiniciado el router. El comando similar write erase limpia la configuración anterior del router.

Ahora podemos salir de la interface de Minicom haciendo el comando de salida Ctrl+A, Q para así asegurarnos que el router no se ha de apagar una vez que salimos de Minicom.


Reseteando el Router

:!: Ver Reseteo Router Cisco.


Actualizado por última vez en 2010-11-18 con trabajo del grupo IV de Redes: César Latorre y Raúl Lopendia

1)
la IP y máscara que nos ha asignado Sistemas
2)
sea cual sea ésta
proyectos/taller-redes/contenidos/configurando-router-cisco.txt · Last modified: 20101119 11:11 by manager